What itunes version is for ipod touch 4?

i have and ipod touch 4 Generation and i have been trying to conect it to the itunes but it keeps showing that my ipod couldn't be detected and that it couldn't be identify and i don't know how to fix it. by the way i have the 11.0.1 itunes version and i don't know if i have to download other version...
Advertisement
Reply

a 4G with iOS 6 requires iTunes 10.7 or later.
To resolve your problem see:
iOS: Device not recognized in iTunes for Windows